R1
Current configuration : 1635 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip cef
!
!
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
voice-card 0
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 10.10.10.1 255.255.255.0
!
interface Loopback1
ip address 10.20.30.1 255.255.255.0
!
interface FastEthernet0/0
ip address 192.168.12.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1/0
no ip address
shutdown
no fair-queue
clock rate 125000
!
interface Serial0/1/1
no ip address
shutdown
clock rate 125000
!
router bgp 64512
no synchronization
bgp log-neighbor-changes
network 10.10.10.0 mask 255.255.255.0
network 10.20.30.0 mask 255.255.255.0
aggregate-address 10.0.0.0 255.0.0.0 attribute-map SUMMARYattribute
neighbor 192.168.12.2 remote-as 64513
neighbor 192.168.12.2 send-community
neighbor 192.168.12.2 route-map SETNOEXPORT out
no auto-summary
!
ip forward-protocol nd
!
!
ip http server
no ip http secure-server
!
!
ip prefix-list LO0network seq 5 permit 10.10.10.0/24
!
route-map SUMMARYattribute permit 10
set community -67108854
!
route-map SETNOEXPORT permit 10
match ip address prefix-list LO0network
set community no-export
!
route-map SETNOEXPORT permit 20
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
privilege level 15
no login
line vty 5 15
privilege level 15
no login
!
scheduler allocate 20000 1000
end
R2
Building configuration...
Current configuration : 1322 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip cef
!
!
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
voice-card 0
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
ip address 192.168.12.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.23.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/1/0
no ip address
shutdown
clock rate 125000
!
interface Serial0/1/1
no ip address
shutdown
clock rate 125000
!
router bgp 64513
no synchronization
bgp log-neighbor-changes
neighbor 192.168.12.1 remote-as 64512
neighbor 192.168.12.1 route-map SETNOADVERTISE in
neighbor 192.168.23.2 remote-as 64513
neighbor 192.168.23.2 next-hop-self
neighbor 192.168.23.2 send-community
no auto-summary
!
ip forward-protocol nd
!
!
ip http server
no ip http secure-server
!
!
route-map SETNOADVERTISE permit 10
match community 64512:10
set community no-advertise
!
route-map SETNOADVERTISE permit 20
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
privilege level 15
no login
line vty 5 15
privilege level 15
no login
!
scheduler allocate 20000 1000
end
R3
Current configuration : 1384 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip cef
!
!
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
voice-card 0
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
ip address 192.168.23.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.34.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/1/0
no ip address
shutdown
no fair-queue
clock rate 2000000
!
interface Serial0/1/1
no ip address
shutdown
clock rate 2000000
!
router bgp 64513
no synchronization
bgp log-neighbor-changes
neighbor 192.168.23.1 remote-as 64513
neighbor 192.168.23.1 route-map SETNOADVERTISE in
neighbor 192.168.34.2 remote-as 64514
neighbor 192.168.34.2 send-community
neighbor 192.168.34.2 route-map SETNOADVERTISE in
no auto-summary
!
ip forward-protocol nd
!
ip community-list 1 permit 4227858442
!
ip http server
no ip http secure-server
!
!
route-map SETNOADVERTISE permit 10
match community 1
set community no-advertise
!
route-map SETNOADVERTISE permit 20
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
privilege level 15
no login
line vty 5 15
privilege level 15
no login
!
scheduler allocate 20000 1000
end
R4
Building configuration...
Current configuration : 1015 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R4
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip cef
!
!
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
voice-card 0
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
ip address 192.168.34.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1/0
no ip address
shutdown
clock rate 125000
!
interface Serial0/1/1
no ip address
shutdown
clock rate 125000
!
router bgp 64514
no synchronization
bgp log-neighbor-changes
neighbor 192.168.34.1 remote-as 64513
no auto-summary
!
ip forward-protocol nd
!
!
ip http server
no ip http secure-server
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
privilege level 15
no login
line vty 5 15
privilege level 15
no login
!
scheduler allocate 20000 1000
end