R1
Current configuration : 1476 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip cef
!
!
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
voice-card 0
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 10.100.100.1 255.255.255.0
!
interface FastEthernet0/0
ip address 192.168.12.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.15.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/1/0
no ip address
shutdown
no fair-queue
clock rate 125000
!
interface Serial0/1/1
no ip address
shutdown
clock rate 125000
!
router bgp 100
no synchronization
bgp log-neighbor-changes
network 10.100.100.0 mask 255.255.255.0
neighbor eBGP peer-group
neighbor eBGP route-map PREFER_AS500 in
neighbor 192.168.12.2 remote-as 201
neighbor 192.168.12.2 peer-group eBGP
neighbor 192.168.15.2 remote-as 500
neighbor 192.168.15.2 peer-group eBGP
no auto-summary
!
ip forward-protocol nd
!
ip as-path access-list 500 permit (.)*_500_(.)*
!
ip http server
no ip http secure-server
!
!
route-map PREFER_AS500 permit 10
match as-path 500
set weight 10
!
route-map PREFER_AS500 permit 20
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
privilege level 15
no login
line vty 5 15
privilege level 15
no login
!
scheduler allocate 20000 1000
end
R2
Building configuration...
Current configuration : 1508 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip cef
!
!
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
voice-card 0
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 10.200.200.1 255.255.255.0
!
interface FastEthernet0/0
ip address 192.168.12.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.23.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/1/0
no ip address
shutdown
clock rate 125000
!
interface Serial0/1/1
no ip address
shutdown
clock rate 125000
!
router bgp 200
no synchronization
bgp log-neighbor-changes
network 10.200.200.0 mask 255.255.255.0
neighbor 192.168.12.1 remote-as 100
neighbor 192.168.12.1 local-as 201 no-prepend replace-as
neighbor 192.168.12.1 route-map SETWEIGHT in
neighbor 192.168.23.2 remote-as 200
neighbor 192.168.23.2 next-hop-self
no auto-summary
!
ip forward-protocol nd
!
!
ip http server
no ip http secure-server
!
!
ip prefix-list prefixAS500 seq 5 permit 10.50.50.0/24
!
route-map SETWEIGHT permit 10
match ip address prefix-list prefixAS500
set local-preference 200
set weight 10
!
route-map SETWEIGHT permit 20
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
privilege level 15
no login
line vty 5 15
privilege level 15
no login
!
scheduler allocate 20000 1000
end
R3
Current configuration : 1116 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip cef
!
!
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
voice-card 0
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
ip address 192.168.23.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.34.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/1/0
no ip address
shutdown
no fair-queue
clock rate 2000000
!
interface Serial0/1/1
no ip address
shutdown
clock rate 2000000
!
router bgp 200
no synchronization
bgp log-neighbor-changes
neighbor 192.168.23.1 remote-as 200
neighbor 192.168.23.1 next-hop-self
neighbor 192.168.34.2 remote-as 300
no auto-summary
!
ip forward-protocol nd
!
!
ip http server
no ip http secure-server
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
privilege level 15
no login
line vty 5 15
privilege level 15
no login
!
scheduler allocate 20000 1000
end
R4
Building configuration...
Current configuration : 1557 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R4
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip cef
!
!
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
voice-card 0
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 10.30.30.1 255.255.255.0
!
interface FastEthernet0/0
ip address 192.168.34.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.45.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/1/0
no ip address
shutdown
clock rate 125000
!
interface Serial0/1/1
no ip address
shutdown
clock rate 125000
!
router bgp 300
no synchronization
bgp log-neighbor-changes
network 10.30.30.0 mask 255.255.255.0
neighbor eBGP peer-group
neighbor eBGP route-map PREFER_AS500 in
neighbor 192.168.34.1 remote-as 200
neighbor 192.168.34.1 peer-group eBGP
neighbor 192.168.45.2 remote-as 500
neighbor 192.168.45.2 peer-group eBGP
no auto-summary
!
ip forward-protocol nd
!
ip as-path access-list 500 permit (.)*_500_(.)*
!
ip http server
no ip http secure-server
!
!
ip prefix-list prefixAS100 seq 5 permit 10.100.100.0/24
!
route-map PREFER_AS500 permit 10
match ip address prefix-list prefixAS100
match as-path 500
set weight 10
!
route-map PREFER_AS500 permit 20
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
privilege level 15
no login
line vty 5 15
privilege level 15
no login
!
scheduler allocate 20000 1000
end
R5
Building configuration...
Current configuration : 1418 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R5
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip cef
!
!
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
voice-card 0
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 10.50.50.1 255.255.255.0
!
interface FastEthernet0/0
ip address 192.168.45.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.15.2 255.255.255.0
duplex auto
speed auto
!
interface Serial0/1/0
no ip address
shutdown
no fair-queue
clock rate 125000
!
interface Serial0/1/1
no ip address
shutdown
clock rate 125000
!
router bgp 500
no synchronization
bgp log-neighbor-changes
network 10.50.50.0 mask 255.255.255.0
neighbor 192.168.15.1 remote-as 100
neighbor 192.168.45.1 remote-as 300
neighbor 192.168.45.1 route-map PATHPREPEND in
no auto-summary
!
ip forward-protocol nd
!
!
ip http server
no ip http secure-server
!
!
ip prefix-list prefixAS200 seq 5 permit 10.200.200.0/24
!
route-map PATHPREPEND permit 10
match ip address prefix-list prefixAS200
set as-path prepend 64512
!
route-map PATHPREPEND permit 20
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
privilege level 15
no login
line vty 5 15
privilege level 15
no login
!
scheduler allocate 20000 1000
end