R1
Building configuration...
Current configuration : 2009 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip cef
!
!
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
ipv6 unicast-routing
ipv6 cef
!
voice-card 0
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Tunnel0
no ip address
no ip redirects
ipv6 address autoconfig
ipv6 unnumbered FastEthernet0/1
tunnel source 192.168.12.1
tunnel mode ipv6ip 6to4
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
ipv6 address 2001:AC1::/64
ipv6 rip RIPTAG2 enable
ipv6 rip RIPTAG1 enable
ipv6 ospf 1 area 0
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
ipv6 address 2002:C0A8:C01::1/48
ipv6 nd ra-interval 5
!
interface Serial0/1/0
ip address 192.168.12.1 255.255.255.0
ipv6 address 2001:DD::1/64
ipv6 address FE80:A1::1 link-local
ipv6 address autoconfig
ipv6 enable
ipv6 rip RIPTAG1 enable
ipv6 ospf 1 area 0
no fair-queue
!
interface Serial0/1/1
ip address 192.168.23.1 255.255.255.0
ipv6 address autoconfig
ipv6 rip RIPTAG2 enable
clock rate 64000
!
router ospf 1
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
!
router bgp 20
no synchronization
bgp router-id 1.1.1.1
bgp log-neighbor-changes
neighbor 2001:DD::2 remote-as 10
neighbor FE80:AC1::2 remote-as 10
no auto-summary
!
address-family ipv6
neighbor 2001:DD::2 activate
neighbor FE80:AC1::2 activate
network 2001:AC1::/64
exit-address-family
!
ip forward-protocol nd
!
!
ip http server
no ip http secure-server
!
access-list 10 permit 192.168.12.1
ipv6 route 2002::/16 Tunnel0
ipv6 router ospf 1
router-id 1.1.1.1
log-adjacency-changes
!
ipv6 router rip RIPTAG1
!
ipv6 router rip RIPTAG2
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
privilege level 15
no login
line vty 5 15
privilege level 15
no login
!
scheduler allocate 20000 1000
end
R2
Current configuration : 1651 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip cef
!
!
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
ipv6 unicast-routing
ipv6 cef
!
voice-card 0
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
ipv6 address 2001:AC2::/64
ipv6 address 2001:AC2::/64 eui-64
ipv6 rip RIPTAG1 enable
ipv6 ospf 1 area 0
!
interface FastEthernet0/1
ip address 192.168.24.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/1/0
ip address 192.168.12.2 255.255.255.0
ipv6 address 2001:DD::2/64
ipv6 address FE80:A1::2 link-local
ipv6 address autoconfig
ipv6 enable
ipv6 rip RIPTAG1 enable
ipv6 ospf 1 area 0
clock rate 64000
!
interface Serial0/1/1
no ip address
shutdown
clock rate 125000
!
router ospf 1
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
!
router bgp 10
no synchronization
bgp router-id 2.2.2.2
bgp log-neighbor-changes
neighbor 2001:DD::1 remote-as 20
neighbor FE80:A1::1 remote-as 20
no auto-summary
!
address-family ipv6
neighbor 2001:DD::1 activate
neighbor FE80:A1::1 activate
network 2001:AC2::/64
exit-address-family
!
ip forward-protocol nd
!
!
ip http server
no ip http secure-server
!
ipv6 router ospf 1
router-id 2.2.2.2
log-adjacency-changes
!
ipv6 router rip RIPTAG1
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
privilege level 15
no login
line vty 5 15
privilege level 15
no login
!
scheduler allocate 20000 1000
end
R3
Building configuration...
Current configuration : 1117 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip cef
!
!
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
ipv6 unicast-routing
!
voice-card 0
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
ipv6 address 2001:AC3::/64 eui-64
ipv6 rip RIPTAG2 enable
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1/0
ip address 192.168.23.2 255.255.255.0
ipv6 address autoconfig
ipv6 rip RIPTAG2 enable
no fair-queue
!
interface Serial0/1/1
no ip address
shutdown
clock rate 2000000
!
router ospf 1
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
!
ip forward-protocol nd
!
!
ip http server
no ip http secure-server
!
ipv6 router rip RIPTAG2
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
privilege level 15
no login
line vty 5 15
privilege level 15
no login
!
scheduler allocate 20000 1000
end
R4
Building configuration...
Current configuration : 1186 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R4
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip cef
!
!
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
ipv6 unicast-routing
!
voice-card 0
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Tunnel0
no ip address
no ip redirects
ipv6 unnumbered FastEthernet0/1
tunnel source 192.168.24.2
tunnel mode ipv6ip 6to4
!
interface FastEthernet0/0
ip address 192.168.24.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
ipv6 address 2002:C0A8:1802::1/48
!
interface Serial0/1/0
no ip address
shutdown
clock rate 125000
!
interface Serial0/1/1
no ip address
shutdown
clock rate 125000
!
router ospf 1
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
!
ip forward-protocol nd
!
!
ip http server
no ip http secure-server
!
ipv6 route 2002::/16 Tunnel0
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
privilege level 15
no login
line vty 5 15
privilege level 15
no login
!
scheduler allocate 20000 1000
end